CommunityCategory: SIP Advanced Email Rules for WooCommercePossible bug with trigger rules using product categories
Lynn Jatania asked 7 months ago
Lynn Jatania replied 7 months ago

We are having a problem with this plugin that looks like it might be a bug.

The problem is when a product has more than one category assigned to it.

In this case, no emails are being sent and no rules are being triggered.

Here are a few examples:
Example A – Product Sweater has one category assigned to it – category “clothes”
We have a SIP email set up to go out for anything with category “clothes” (“contain”, not “exact match”)
–> this works, email is sent and received.

Example B – Product Discount Shirt has two categories assigned to it – category “clothes” and category “sale”
We have a SIP email set up to go out for anything with category “clothes” (“contain”, not “exact match”)
–> this fails, email is not sent, does not show up in the log, and is not received.

Example C – Product Discount Coat has three categories assigned to it – category “clothes,” category “sale,” and category “coats”
We have SIP emails set up to trigger on category “clothes” and a different one set up to trigger on category “coats” (both “contain”, not “exact match”)
–> NEITHER of the emails go out, nothing is logged, emails are not received.

This looks to me like a bug in the plugin – I am guessing that when there is more than one category, each must be checked from an array, rather than a simple string. Can this be fixed?

4 Answers
Hafiz Muhammad Usman Staff answered 7 months ago

Hi Lynn Jatania,
I understand the issue, can you share the screenshot of that rule which is not sending mail.

Lynn Jatania answered 7 months ago

I’ve attached it.

Lynn Jatania replied 7 months ago

Hm, looks like that didn’t work. Here’s the link:
https://drive.google.com/open?id=1p6C_UHIXqhJ6IaGK_5i1DgimCx5F-n2b

Hafiz Muhammad Usman Staff replied 7 months ago

ok, let me check.

Lynn Jatania answered 7 months ago

Hi, any progress on this? We are waiting for a fix.

Hafiz Muhammad Usman Staff replied 7 months ago

I will work on this in this week.

Lynn Jatania replied 6 months ago

Just popping in to see if this was ever resolved. Still waiting for a fix!

Lynn Jatania answered 6 months ago

bumping this up again – is the fix ready to go? 

Hafiz Muhammad Usman Staff replied 6 months ago

You don’t have try the update yet. Please try the update and let me know your issue is resolve or not.

Hafiz Muhammad Usman Staff replied 6 months ago

Are you have check? and if issue is not resolve please share the screenshot which you have created.